Petit logo latituderhum.com

latituderhum.com

Latitude rhum ou l'attitude rhum par Frank Gygli

Ruses pour Microsoft Excel

Page mise à jour le 06.12.2017

Mélanger texte, chiffres et formules dans la même cellule

Il se peut que l'on souhaite avoir un contenu dynamique dans une cellule, avec un texte "fixe et une année mise à jour automatiquement... les signes magiques sont le & et les " " pour le texte.

Exemple 1 :

la formule :

="Budget "&ANNEE(AUJOURDHUI())

aura pour résultat (donc affichera) : Budget 2017 et cela du 1er janvier au 31 décembre,

mais elle affichera Budget 2018 dès le 1er janvier 2018...

Exemple 2 :

la formule :

="Budget prévisionnel "&ANNEE(AUJOURDHUI())+1

affichera Budget prévisionnel 2018 et cela du 1er janvier au 31 décembre,

mais elle affichera Budget prévisionnel 2019 dès le 1er janvier 2018...

Exemple 3 :

dans cet exemple, on trouve une formule un peu plus complexe qui opère un changement de résultat en fonction du contenu d'une autre cellule... on souhaite dans ce cas, que le résultat ne change que si l'on change le contenu de la cellule D1 (qui a un contenu fixe, ici une date).

la formule :

=SI(ANNEE(AUJOURDHUI())=ANNEE(D1);"Budget "&ANNEE(D1);"Budget prévisionnel "&ANNEE(D1))

affichera Budget 2017 si la date dans la cellule D1 est le jj.mm.2017

et Budget prévisionnel 2018 si la date est le jj.mm.2018.

Séparateur

Afficher le nom d'un onglet dans une cellule

Taper la formule ci-dessous dans la cellule qui doit afficher le nom de l'onglet :

=STXT(CELLULE("nom-fichier";A1);TROUVE("]";CELLULE("nom-fichier";A1))+1;32)

 
NE PAS METTRE LE TRAIT D'UNION ENTRE NOM ET FICHIER
(j'ai dû le mettre pour une question d'affichage de cette page dans Safari)

NB : Si vous utilisez un espace "Cloud" (OneDrive, Google Drive, Dropbox, iCloud, etc.) et une App (p. ex. WPS Office) pour lire vos classeurs Excel, il faut une compatibilité multilingue (français- anglais)... dans ces conditions, adoptez plutôt la formule ci-dessous :

=STXT(CELLULE("file-name";A1);TROUVE("]";CELLULE("filen-ame";A1))+1;32)

 
NE PAS METTRE LE TRAIT D'UNION ENTRE FILE ET NAME
(j'ai dû le mettre pour une question d'affichage de cette page dans Safari)

elle sera reconnue par Excel en français et Excel en anglais. WPS Office la traduira comme suit :

=MID(CELL("file-name";A1);FIND("]";CELL("file-name";A1))+1;32)

 
NE PAS METTRE LE TRAIT D'UNION ENTRE FILE ET NAME
(j'ai dû le mettre pour une question d'affichage de cette page dans Safari)

et n'affichera plus le vilain #VALEUR

(parfois, si le nom de l'onglet est le même que celui du classeur, Excel affichera le vilain #VALEUR...)


Accueil | Bière | Photos | Piment | Proverbes créoles | Rhum | Tout sur Frank | Les (autres) publications